<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/js/167ab40beef1fb4924008e796614e20bf1e26822_https.js" as="script">
<link rel="preload" href="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/css/ac3764b770be71fba50cb9d4bc42af130dcdd5ef_https.css" as="style">
<link rel="stylesheet" href="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/css/ac3764b770be71fba50cb9d4bc42af130dcdd5ef_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.harrodsburgherald.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.harrodsburgherald.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.harrodsburgherald.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Bulldogs Win Big With Small Ball &#8211; The Harrodsburg Herald</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="The Harrodsburg Herald &raquo; Feed" href="https://www.harrodsburgherald.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Harrodsburg Herald &raquo; Comments Feed" href="https://www.harrodsburgherald.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Harrodsburg Herald &raquo; Bulldogs Win Big With Small Ball Comments Feed" href="https://www.harrodsburgherald.com/2021/04/21/bulldogs-win-big-with-small-ball/feed/" /> <meta property="og:title" content="Bulldogs Win Big With Small Ball"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.harrodsburgherald.com/2021/04/21/bulldogs-win-big-with-small-ball/"/><meta property="og:site_name" content="The Harrodsburg Herald"/><meta property="og:image" content="https://www.harrodsburgherald.com/wp-content/uploads/2021/04/Burgin-Baseball-for-web-e1619025247374.jpg"/>                      <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.harrodsburgherald.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                   <link rel="https://api.w.org/" href="https://www.harrodsburgherald.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.harrodsburgherald.com/wp-json/wp/v2/posts/241098" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.harrodsburgherald.com/xmlrpc.php?rsd" /> <link rel='prev' title='Calhoun Indicted For 2020 Murder' href='https://www.harrodsburgherald.com/2021/04/21/calhoun-indicted-for-2020-murder/' /> <link rel='next' title='Mercer Wins Three Straight District Games' href='https://www.harrodsburgherald.com/2021/04/21/mercer-wins-three-straight-district-games/' /> <link rel="canonical" href="https://www.harrodsburgherald.com/2021/04/21/bulldogs-win-big-with-small-ball/" /> <link rel='shortlink' href='https://www.harrodsburgherald.com/?p=241098' /> <link rel="alternate" type="application/json+oembed" href="https://www.harrodsburgherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.harrodsburgherald.com%2F2021%2F04%2F21%2Fbulldogs-win-big-with-small-ball%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.harrodsburgherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.harrodsburgherald.com%2F2021%2F04%2F21%2Fbulldogs-win-big-with-small-ball%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.harrodsburgherald.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=5.5.3' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/js/167ab40beef1fb4924008e796614e20bf1e26822_https.js"></script></head> <body class="post-template-default single single-post postid-241098 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2></h2><span></span></div> <ul> <li><a href="https://www.harrodsburgherald.com/2021/04/21/mercer-wins-three-straight-district-games/">Mercer Wins Three Straight District Games</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/bulldogs-win-big-with-small-ball/">Bulldogs Win Big With Small Ball</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/calhoun-indicted-for-2020-murder/">Calhoun Indicted For 2020 Murder</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/rebels-serve-titans-with-a-loss/">Rebels Serve Titans With A Loss</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/win-big-and-support-mental-health-at-spring-festival/">Win Big And Support Mental Health At Spring Festival</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/public-hearing-on-zoning-amendment-to-allow-drug-treatment-centers-in-harrodsburg/">Public Hearing On Zoning Amendment To Allow Drug Treatment Centers In Harrodsburg</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/lady-titans-drop-two-in-tri-state-showcase/">Lady Titans Drop Two In Tri-State Showcase</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/tyler-indicted-for-new-years-break-in/">Tyler Indicted For New Year&#8217;s Break-In</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/21/two-local-men-killed-in-casey-county-crash/">Two Local Men Killed In Casey County Crash</a></li> <li><a href="https://www.harrodsburgherald.com/2021/04/20/local-man-arrested-in-alleged-connection-to-jan-6-capitol-assault/">Local Man Arrested For Alleged Role In Jan. 6 U.S. Capitol Assault</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-footer-menu-1" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-232"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0&#038;view=archives">Archives</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="https://www.harrodsburgherald.com/">Home</a></li> <li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0">E-Edition</a></li> <li id="menu-item-225505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-225505"><a href="https://www.harrodsburgherald.com/photo-galleries/">Photo Galleries</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.harrodsburgherald.com/contact-us/">Contact Us</a></li> <li id="menu-item-236385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236385"><a target="_blank" rel="noopener noreferrer" href="https://2124.newstogo.us/editionviewer/default.aspx?Edition=fe18dace-4983-4970-a7dc-41c3f49532dd">Bluegrass Sports Roundup</a></li> </ul><div class="fl-social-icons"><a href="/cdn-cgi/l/email-protection#d9b8bcb5b5b0aa99b1b8ababb6bdaabbacabbeb1bcabb8b5bdf7bab6b4" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.harrodsburgherald.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.harrodsburgherald.com/wp-content/uploads/2016/08/mast.png" data-retina="" alt="The Harrodsburg Herald" /><meta itemprop="name" content="The Harrodsburg Herald" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-40330" class="widget widget-webads-weather"> <a id="webads-weather-40330-link" href="https://www.harrodsburgherald.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-40330-temperature" class="temperature"></span> <i id="webads-weather-40330-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-40330-location" class="location"></span> <span id="webads-weather-40330-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076"><a href="https://www.harrodsburgherald.com/">Home</a></li> <li id="menu-item-19512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19512"><a href="#">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-296"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0">The Harrodsburg Herald</a></li> <li id="menu-item-18658" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18658"><a target="_blank" rel="noopener noreferrer" href="https://2124.newstogo.us/editionviewer/default.aspx?Edition=62bf77ca-d4a0-488e-b530-1f33436947b4">Bluegrass Sports Roundup</a></li> <li id="menu-item-18656" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18656"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=dc0921ec-581e-4533-901d-77da41de7359">Mercer Magazine</a></li> </ul> </li> <li id="menu-item-236527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236527"><a href="https://www.harrodsburgherald.com/videos-to-view/">Videos</a></li> <li id="menu-item-767" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-767"><a href="https://www.harrodsburgherald.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243"><a href="#">Regional News</a> <ul class="sub-menu"> <li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246"><a href="https://www.harrodsburgherald.com/kentucky-news/">Kentucky News</a></li> <li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244"><a href="https://www.harrodsburgherald.com/frankfurt-news/">Frankfort News</a></li> </ul> </li> </ul> </li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-766"><a href="https://www.harrodsburgherald.com/category/sports/">Sports</a></li> <li id="menu-item-29777" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29777"><a href="https://www.harrodsburgherald.com/category/obituaries/">Obituaries</a></li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-107025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-107025"><a href="https://www.harrodsburgherald.com/photo-galleries/">Photos</a> <ul class="sub-menu"> <li id="menu-item-19462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19462"><a target="_blank" rel="noopener noreferrer" href="http://form.jotform.us/form/51965181971161">Order Photos</a></li> </ul> </li> <li id="menu-item-19464" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19464"><a href="#">Connect</a> <ul class="sub-menu"> <li id="menu-item-19511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19511"><a href="https://www.harrodsburgherald.com/contact-us/">Contact Us</a></li> <li id="menu-item-231854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231854"><a href="https://www.harrodsburgherald.com/event-calendar/">Events</a></li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://www.harrodsburgherald.com/crossword/">Crossword</a></li> </ul> </li> <li id="menu-item-19451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19451"><a href="#">Newsroom and Society Forms</a> <ul class="sub-menu"> <li id="menu-item-19510" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19510"><a href="#">Deadlines</a> <ul class="sub-menu"> <li id="menu-item-19509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19509"><a href="https://www.harrodsburgherald.com/news-deadlines/">News Deadlines</a></li> <li id="menu-item-19508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19508"><a href="https://www.harrodsburgherald.com/ad-deadlines/">Ad Deadlines</a></li> </ul> </li> <li id="menu-item-19450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19450"><a href="https://www.harrodsburgherald.com/anniversary-form/">Anniversary Form</a></li> <li id="menu-item-19449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19449"><a href="https://www.harrodsburgherald.com/birth-annoucement/">Birth Annoucement</a></li> <li id="menu-item-19448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19448"><a href="https://www.harrodsburgherald.com/happy-1st-birthday/">Happy 1st Birthday</a></li> <li id="menu-item-19447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19447"><a href="https://www.harrodsburgherald.com/upcoming-nuptials/">Upcoming Nuptials</a></li> <li id="menu-item-19446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19446"><a href="https://www.harrodsburgherald.com/wedding-announcement-form/">Wedding Announcement Form</a></li> </ul> </li> <li id="menu-item-19513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19513"><a href="#">Local Links</a> <ul class="sub-menu"> <li id="menu-item-21625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21625"><a href="https://www.harrodsburgherald.com/churches/">Churches</a></li> <li id="menu-item-21624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21624"><a href="https://www.harrodsburgherald.com/21605-2/">Banking &#038; Finance</a></li> <li id="menu-item-21623" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21623"><a href="https://www.harrodsburgherald.com/funeral-homes/">Funeral Homes</a></li> <li id="menu-item-21622" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21622"><a href="https://www.harrodsburgherald.com/local-governmentorganizations/">Local Government &#038; Organizations</a></li> <li id="menu-item-21621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21621"><a href="https://www.harrodsburgherald.com/real-estate/">Real Estate</a></li> <li id="menu-item-21620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21620"><a href="https://www.harrodsburgherald.com/schools/">Schools</a></li> <li id="menu-item-21619" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21619"><a href="https://www.harrodsburgherald.com/21616-2/">Tourist Attractions</a></li> </ul> </li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.harrodsburgherald.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-241098 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-sports" id="fl-post-241098" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Bulldogs Win Big With Small Ball </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.harrodsburgherald.com/author/editor/" itemprop="url"><span itemprop="name">Harrodsburg Herald</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-04-21">April 21, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.harrodsburgherald.com/2021/04/21/bulldogs-win-big-with-small-ball/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.harrodsburgherald.com/wp-content/uploads/2021/04/Burgin-Baseball-for-web-e1619025247374.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <div id="attachment_241076" style="width: 1130px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-241076" loading="lazy" class="size-full wp-image-241076" src="https://www.harrodsburgherald.com/wp-content/uploads/2021/04/Burgin-Baseball-for-web-e1619025247374.jpg" alt="" width="1120" height="630" /><p id="caption-attachment-241076" class="wp-caption-text"><strong><em>The Harrodsburg Herald</em>/Doug Brown</strong><br /><strong>Cameron Nagel scores a run during a recent win for Burgin. The Bulldogs have had big success recently playing small ball, scoring thanks to aggressive base running and heads up play.</strong></p></div> <p class="p1"><span class="s1"><b>Doug Brown</b></span></p> <p class="p2"><span class="s1"><b>Herald Staff</b></span></p> <p class="p3"><span class="s1"><b><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="2350534c515750634b4251514c4750415651444b4651424f470d404c4e">[email&#160;protected]</a></b></span></p> <p class="p5"><span class="s1">The Burgin Bulldogs (2-7) earned their second win of the season against the St. Francis Wyverns (0-3) on Friday, April 16, 14-2. Aggressive base running led the Bulldogs to victory.</span></p> <p class="p5"><span class="s1">“I thought we came out and swung really well. I was pleased with the way we swung the bats,” said Burgin Head Coach Donnie Edwards. “I thought our pitchers did a good job. It was Eli Newby’s first action on the mound with us and I thought he did a good job. Hunter Reed came in and finished the deal. I’m just really happy to get a ‘W’ and have everybody participate in the ballgame. It’s a good momentum builder for the weekend.”</span></p> <p class="p5"><span class="s1">The first inning began with sophomore Jacob Qualls being walked to first base, then stealing second and third. Qualls scored the first run of the game alongside senior Jackson Qualls in a double play.</span></p> <h3>For more, check out this week’s edition of <em>the Harrodsburg Herald.</em> <a href="https://2124.newstogo.us/editionviewer/default.aspx?view=subscribe&amp;Edition=e906a6fc-7c4a-45df-b81f-fe86f6560d86">Click here to subscribe to the online version.</a></h3> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.harrodsburgherald.com/2021/04/21/bulldogs-win-big-with-small-ball/" data-a2a-title="Bulldogs Win Big With Small Ball"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.harrodsburgherald.com%2F2021%2F04%2F21%2Fbulldogs-win-big-with-small-ball%2F&amp;linkname=Bulldogs%20Win%20Big%20With%20Small%20Ball" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.harrodsburgherald.com%2F2021%2F04%2F21%2Fbulldogs-win-big-with-small-ball%2F&amp;linkname=Bulldogs%20Win%20Big%20With%20Small%20Ball" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.harrodsburgherald.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.harrodsburgherald.com/category/sports/" rel="category tag">Sports</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.harrodsburgherald.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='241098' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/21/bulldogs-win-big-with-small-ball/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2021/04/21/mercer-wins-three-straight-district-games/" rel="bookmark" title="Mercer Wins Three Straight District Games"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2021/04/Landon_-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2021/04/21/mercer-wins-three-straight-district-games/" rel="bookmark" title="Mercer Wins Three Straight District Games">Mercer Wins Three Straight District Games</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 21, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2021/04/21/mercer-wins-three-straight-district-games/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2021/04/21/calhoun-indicted-for-2020-murder/" rel="bookmark" title="Calhoun Indicted For 2020 Murder"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2021/02/GERALD-CALHOUN-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2021/04/21/calhoun-indicted-for-2020-murder/" rel="bookmark" title="Calhoun Indicted For 2020 Murder">Calhoun Indicted For 2020 Murder</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 21, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2021/04/21/calhoun-indicted-for-2020-murder/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2021/04/21/rebels-serve-titans-with-a-loss/" rel="bookmark" title="Rebels Serve Titans With A Loss"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2021/04/Tennis-for-web-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2021/04/21/rebels-serve-titans-with-a-loss/" rel="bookmark" title="Rebels Serve Titans With A Loss">Rebels Serve Titans With A Loss</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 21, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2021/04/21/rebels-serve-titans-with-a-loss/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2021/04/21/win-big-and-support-mental-health-at-spring-festival/" rel="bookmark" title="Win Big And Support Mental Health At Spring Festival"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2021/04/Susan-and-Noel-Turner-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2021/04/21/win-big-and-support-mental-health-at-spring-festival/" rel="bookmark" title="Win Big And Support Mental Health At Spring Festival">Win Big And Support Mental Health At Spring Festival</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 21, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2021/04/21/win-big-and-support-mental-health-at-spring-festival/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2021/04/21/public-hearing-on-zoning-amendment-to-allow-drug-treatment-centers-in-harrodsburg/" rel="bookmark" title="Public Hearing On Zoning Amendment To Allow Drug Treatment Centers In Harrodsburg"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2019/06/Planning-and-Zoning-Sign-Night-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2021/04/21/public-hearing-on-zoning-amendment-to-allow-drug-treatment-centers-in-harrodsburg/" rel="bookmark" title="Public Hearing On Zoning Amendment To Allow Drug Treatment Centers In Harrodsburg">Public Hearing On Zoning Amendment To Allow Drug Treatment Centers In Harrodsburg</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> April 21, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2021/04/21/public-hearing-on-zoning-amendment-to-allow-drug-treatment-centers-in-harrodsburg/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', '101 Ad', 1.00, {'nonInteraction': 1});" href="http://cometo101.com/" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', '101 Ad', 2.00, {'nonInteraction': 1});" src="https://www.harrodsburgherald.com/wp-content/uploads/2020/04/image0.gif" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (13) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>            
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 4.69090915 sec
Time to load cache: 0.5491209
Cache file created on: 2021-04-21T17:51:40+00:00
Current time: 2021-04-21T17:53:00+00:00
-->