<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/js/4e07bb1139d16b6de62fb3234cbb80a22fc5920b_https.js" as="script">
<link rel="preload" href="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/css/dc8e40a18b060fd6330dbd77b04c2d9a7a888c87_https.css" as="style">
<link rel="stylesheet" href="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/css/dc8e40a18b060fd6330dbd77b04c2d9a7a888c87_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="http://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.harrodsburgherald.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.harrodsburgherald.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.harrodsburgherald.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Three District Judge Nominees To Appear At Election Forum On May 10 &#8211; The Harrodsburg Herald</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="The Harrodsburg Herald &raquo; Feed" href="https://www.harrodsburgherald.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Harrodsburg Herald &raquo; Comments Feed" href="https://www.harrodsburgherald.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="The Harrodsburg Herald &raquo; Three District Judge Nominees To Appear At Election Forum On May 10 Comments Feed" href="https://www.harrodsburgherald.com/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/feed/" /> <meta property="og:title" content="Three District Judge Nominees To Appear At Election Forum On May 10"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.harrodsburgherald.com/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/"/><meta property="og:site_name" content="The Harrodsburg Herald"/><meta property="og:image" content="https://www.harrodsburgherald.com/wp-content/uploads/2019/08/Judicial-Center-and-Cloud-4.jpg"/>                       <style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.harrodsburgherald.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                        <link rel="https://api.w.org/" href="https://www.harrodsburgherald.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.harrodsburgherald.com/wp-json/wp/v2/posts/246055" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.harrodsburgherald.com/xmlrpc.php?rsd" /> <link rel='prev' title='Titans Sweep Bulldogs In Intercounty Matchup' href='https://www.harrodsburgherald.com/2022/05/04/titans-sweep-bulldogs-in-intercounty-matchup/' /> <link rel='next' title='Russ Yeast Wraps Up NFL Draft Pick' href='https://www.harrodsburgherald.com/2022/05/04/russ-yeast-wraps-up-nfl-draft-pick/' /> <link rel="canonical" href="https://www.harrodsburgherald.com/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/" /> <link rel='shortlink' href='https://www.harrodsburgherald.com/?p=246055' /> <link rel="alternate" type="application/json+oembed" href="https://www.harrodsburgherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.harrodsburgherald.com%2F2022%2F05%2F04%2Fthree-district-judge-nominees-to-appear-at-election-forum-on-may-10%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.harrodsburgherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.harrodsburgherald.com%2F2022%2F05%2F04%2Fthree-district-judge-nominees-to-appear-at-election-forum-on-may-10%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.harrodsburgherald.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/> <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script src='https://www.google.com/recaptcha/api.js?ver=5.5.9' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.harrodsburgherald.com/wp-content/cache/borlabs_cache/1/js/4e07bb1139d16b6de62fb3234cbb80a22fc5920b_https.js"></script></head> <body class="post-template-default single single-post postid-246055 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2></h2><span></span></div> <ul> <li><a href="https://www.harrodsburgherald.com/2022/05/04/sailing-into-the-sunset-shakertown-closes-riverboat-cruise/">Sailing Into The Sunset: Shakertown Closes Riverboat Cruise</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/russ-yeast-wraps-up-nfl-draft-pick/">Russ Yeast Wraps Up NFL Draft Pick</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/">Three District Judge Nominees To Appear At Election Forum On May 10</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/titans-sweep-bulldogs-in-intercounty-matchup/">Titans Sweep Bulldogs In Intercounty Matchup</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/mercer-boys-and-girls-track-dominate-danville-allcomers/">Mercer Boys And Girls Track Dominate Danville Allcomers</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/talking-with-sandra-defoor-about-the-mercer-county-health-department/">Talking With Sandra DeFoor About The Mercer County Health Department</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/injury-plagued-mercer-softball-squad-falls-to-scott-county/">Injury Plagued Mercer Softball Squad Falls To Scott County</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/online-production-of-the-kentucky-cycle-to-benefit-tornado-victims-on-may-12/">Online Production Of &#8216;The Kentucky Cycle&#8217; To Benefit Tornado Victims On May 12</a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/tracking-improvement-burgin-girls-finish-4th-at-danville-all-comers/">Tracking Improvement: Burgin Girls Finish 4th At Danville All Comers </a></li> <li><a href="https://www.harrodsburgherald.com/2022/05/04/blood-drive-on-wednesday-may-11/">Blood Drive On Wednesday, May 11</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-footer-menu-1" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-232 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0&#038;view=archives" class="nav-link">Archives</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0&#038;view=subscribe" class="nav-link">Subscribe</a></li> <li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228 nav-item"><a href="https://www.harrodsburgherald.com/" class="nav-link">Home</a></li> <li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0" class="nav-link">E-Edition</a></li> <li id="menu-item-225505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-225505 nav-item"><a href="https://www.harrodsburgherald.com/photo-galleries/" class="nav-link">Photo Galleries</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229 nav-item"><a href="https://www.harrodsburgherald.com/contact-us/" class="nav-link">Contact Us</a></li> </ul> <div class="fl-social-icons"> <a href="mailto:aellis@harrodsburgherald.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div> </div> </div> </div> </div> </div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.harrodsburgherald.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.harrodsburgherald.com/wp-content/uploads/2016/08/mast.png" data-retina="" title="" alt="The Harrodsburg Herald" /><meta itemprop="name" content="The Harrodsburg Herald" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-40330" class="widget widget-webads-weather"> <a id="webads-weather-40330-link" href="https://www.harrodsburgherald.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-40330-temperature" class="temperature"></span> <i id="webads-weather-40330-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-40330-location" class="location"></span> <span id="webads-weather-40330-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076 nav-item"><a href="https://www.harrodsburgherald.com/" class="nav-link">Home</a></li> <li id="menu-item-19512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19512 nav-item"><a href="#" class="nav-link">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-296 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0" class="nav-link">The Harrodsburg Herald</a></li> <li id="menu-item-18658" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18658 nav-item"><a target="_blank" rel="noopener noreferrer" href="https://2124.newstogo.us/editionviewer/default.aspx?Edition=62bf77ca-d4a0-488e-b530-1f33436947b4" class="nav-link">Bluegrass Sports Roundup</a></li> <li id="menu-item-18656" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18656 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=dc0921ec-581e-4533-901d-77da41de7359" class="nav-link">Mercer Magazine</a></li> </ul> </li> <li id="menu-item-236527" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-236527 nav-item"><a href="https://www.harrodsburgherald.com/videos-to-view/" class="nav-link">Videos</a></li> <li id="menu-item-767" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-767 nav-item"><a href="https://www.harrodsburgherald.com/category/news/" class="nav-link">News</a> <ul class="sub-menu"> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243 nav-item"><a href="#" class="nav-link">Regional News</a> <ul class="sub-menu"> <li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246 nav-item"><a href="https://www.harrodsburgherald.com/kentucky-news/" class="nav-link">Kentucky News</a></li> <li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244 nav-item"><a href="https://www.harrodsburgherald.com/frankfurt-news/" class="nav-link">Frankfort News</a></li> </ul> </li> </ul> </li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766 nav-item"><a href="https://www.harrodsburgherald.com/category/sports/" class="nav-link">Sports</a></li> <li id="menu-item-29777" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29777 nav-item"><a href="https://www.harrodsburgherald.com/category/obituaries/" class="nav-link">Obituaries</a></li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://2124.newstogo.us/editionviewer/default.aspx?Publication=a2e8ebf0-bfad-4642-bcfb-e9c9551777d0&#038;view=subscribe" class="nav-link">Subscribe</a></li> <li id="menu-item-107025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-107025 nav-item"><a href="https://www.harrodsburgherald.com/photo-galleries/" class="nav-link">Photos</a> <ul class="sub-menu"> <li id="menu-item-19462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19462 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://form.jotform.us/form/51965181971161" class="nav-link">Order Photos</a></li> </ul> </li> <li id="menu-item-19464" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19464 nav-item"><a href="#" class="nav-link">Connect</a> <ul class="sub-menu"> <li id="menu-item-19511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19511 nav-item"><a href="https://www.harrodsburgherald.com/contact-us/" class="nav-link">Contact Us</a></li> <li id="menu-item-231854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-231854 nav-item"><a href="https://www.harrodsburgherald.com/event-calendar/" class="nav-link">Events</a></li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289 nav-item"><a href="https://www.harrodsburgherald.com/crossword/" class="nav-link">Crossword</a></li> </ul> </li> <li id="menu-item-19451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19451 nav-item"><a href="#" class="nav-link">Newsroom and Society Forms</a> <ul class="sub-menu"> <li id="menu-item-19510" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19510 nav-item"><a href="#" class="nav-link">Deadlines</a> <ul class="sub-menu"> <li id="menu-item-19509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19509 nav-item"><a href="https://www.harrodsburgherald.com/news-deadlines/" class="nav-link">News Deadlines</a></li> <li id="menu-item-19508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19508 nav-item"><a href="https://www.harrodsburgherald.com/ad-deadlines/" class="nav-link">Ad Deadlines</a></li> </ul> </li> <li id="menu-item-19450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19450 nav-item"><a href="https://www.harrodsburgherald.com/anniversary-form/" class="nav-link">Anniversary Form</a></li> <li id="menu-item-19449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19449 nav-item"><a href="https://www.harrodsburgherald.com/birth-annoucement/" class="nav-link">Birth Annoucement</a></li> <li id="menu-item-19448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19448 nav-item"><a href="https://www.harrodsburgherald.com/happy-1st-birthday/" class="nav-link">Happy 1st Birthday</a></li> <li id="menu-item-19447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19447 nav-item"><a href="https://www.harrodsburgherald.com/upcoming-nuptials/" class="nav-link">Upcoming Nuptials</a></li> <li id="menu-item-19446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19446 nav-item"><a href="https://www.harrodsburgherald.com/wedding-announcement-form/" class="nav-link">Wedding Announcement Form</a></li> </ul> </li> <li id="menu-item-19513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19513 nav-item"><a href="#" class="nav-link">Local Links</a> <ul class="sub-menu"> <li id="menu-item-21625" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21625 nav-item"><a href="https://www.harrodsburgherald.com/churches/" class="nav-link">Churches</a></li> <li id="menu-item-21624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21624 nav-item"><a href="https://www.harrodsburgherald.com/21605-2/" class="nav-link">Banking &#038; Finance</a></li> <li id="menu-item-21623" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21623 nav-item"><a href="https://www.harrodsburgherald.com/funeral-homes/" class="nav-link">Funeral Homes</a></li> <li id="menu-item-21622" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21622 nav-item"><a href="https://www.harrodsburgherald.com/local-governmentorganizations/" class="nav-link">Local Government &#038; Organizations</a></li> <li id="menu-item-21621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21621 nav-item"><a href="https://www.harrodsburgherald.com/real-estate/" class="nav-link">Real Estate</a></li> <li id="menu-item-21620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21620 nav-item"><a href="https://www.harrodsburgherald.com/schools/" class="nav-link">Schools</a></li> <li id="menu-item-21619" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21619 nav-item"><a href="https://www.harrodsburgherald.com/21616-2/" class="nav-link">Tourist Attractions</a></li> </ul> </li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.harrodsburgherald.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-246055 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-news" id="fl-post-246055" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Three District Judge Nominees To Appear At Election Forum On May 10 </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.harrodsburgherald.com/author/editor/" itemprop="url"><span itemprop="name">Harrodsburg Herald</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2022-05-04">May 4, 2022</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.harrodsburgherald.com/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.harrodsburgherald.com/wp-content/uploads/2019/08/Judicial-Center-and-Cloud-4.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <p><strong>Robert Moore</strong><br /> <strong>Herald Staff</strong><br /> <strong>rmoore@harrodsburgherald.com</strong></p> <p>The Judicial Nominating Commission has announced nominees to fill the District Court judicial vacancy for Boyle and Mercer counties. The counties make up the 50th Judicial District and the vacancy is in the district’s Division I.</p> <p>The judicial seat became vacant in March, when Judge Jeffrey Dotson was appointed Circuit Court judge for the 50th Judicial Circuit of Boyle and Mercer counties. Two retired judges—Dan Kelly and Jeffrey Walson—are handling the district court caseload until an appointment is made, according to the Mercer County Clerk&#8217;s Office.</p> <p>The three nominees for the judgeship are attorneys Patrick Francis Barsotti of Danville, Stacy Elizabeth Coontz of Junction City and Christopher Joel Reed of Danville.</p> <p>Barsotti currently serves as an assistant county attorney for Boyle County. He received his juris doctor from the University of Kentucky College of Law, now the University of Kentucky J. David Rosenberg College of Law.</p> <p>Coontz is in private practice with Helton Law Office. She received her juris doctor from the University of Kentucky College of Law, now the University of Kentucky J. David Rosenberg College of Law.</p> <p>Reed has his own private law practice. He received his juris doctor from Florida Coastal School of Law.</p> <p>Barasotti, Coontz and Reed are all running to be elected District Court Judge. All three are slated to appear at the 2022 Mercer County Primary Election Political Candidate Forum on Tuesday, May 10, starting 6:30 p.m. at Lions Park Community Center (450 East Factory Street, Harrodsburg). Also appearing at the forum will be candidates for constable district 3, magistrate districts 1–5, county judge executive and state representative.</p> <p>The general election will be held Tuesday, Nov. 8.</p> <h2 class="western"><strong>For the rest of the story, check out this week&#8217;s issue of </strong><em>the Harrodsburg Herald. </em><strong><u>Click here to <a href="https://2124.newstogo.us/editionviewer/default.aspx?view=subscribe&amp;Edition=ff52e8c6-d09a-41ad-ad9f-8b1c586f27e4">subscribe.</a></u></strong></h2> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.harrodsburgherald.com/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/" data-a2a-title="Three District Judge Nominees To Appear At Election Forum On May 10"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.harrodsburgherald.com%2F2022%2F05%2F04%2Fthree-district-judge-nominees-to-appear-at-election-forum-on-may-10%2F&amp;linkname=Three%20District%20Judge%20Nominees%20To%20Appear%20At%20Election%20Forum%20On%20May%2010" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.harrodsburgherald.com%2F2022%2F05%2F04%2Fthree-district-judge-nominees-to-appear-at-election-forum-on-may-10%2F&amp;linkname=Three%20District%20Judge%20Nominees%20To%20Appear%20At%20Election%20Forum%20On%20May%2010" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.harrodsburgherald.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.harrodsburgherald.com/category/news/" rel="category tag">News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.harrodsburgherald.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='246055' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_0c74b7f78409a4022a2c4c5a5ca3ee19" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/04/three-district-judge-nominees-to-appear-at-election-forum-on-may-10/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2022/05/04/sailing-into-the-sunset-shakertown-closes-riverboat-cruise/" rel="bookmark" title="Sailing Into The Sunset: Shakertown Closes Riverboat Cruise"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2022/05/dixie-belle-at-Shakertown-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2022/05/04/sailing-into-the-sunset-shakertown-closes-riverboat-cruise/" rel="bookmark" title="Sailing Into The Sunset: Shakertown Closes Riverboat Cruise">Sailing Into The Sunset: Shakertown Closes Riverboat Cruise</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2022/05/04/sailing-into-the-sunset-shakertown-closes-riverboat-cruise/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2022/05/04/russ-yeast-wraps-up-nfl-draft-pick/" rel="bookmark" title="Russ Yeast Wraps Up NFL Draft Pick"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2022/05/Russ-Yeast-KState-5-5-2022-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2022/05/04/russ-yeast-wraps-up-nfl-draft-pick/" rel="bookmark" title="Russ Yeast Wraps Up NFL Draft Pick">Russ Yeast Wraps Up NFL Draft Pick</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2022/05/04/russ-yeast-wraps-up-nfl-draft-pick/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2022/05/04/titans-sweep-bulldogs-in-intercounty-matchup/" rel="bookmark" title="Titans Sweep Bulldogs In Intercounty Matchup"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2022/05/IMG_4704-e1651685319391-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2022/05/04/titans-sweep-bulldogs-in-intercounty-matchup/" rel="bookmark" title="Titans Sweep Bulldogs In Intercounty Matchup">Titans Sweep Bulldogs In Intercounty Matchup</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2022/05/04/titans-sweep-bulldogs-in-intercounty-matchup/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2022/05/04/mercer-boys-and-girls-track-dominate-danville-allcomers/" rel="bookmark" title="Mercer Boys And Girls Track Dominate Danville Allcomers"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2022/05/beau-and-Matthew-e1651684049544-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2022/05/04/mercer-boys-and-girls-track-dominate-danville-allcomers/" rel="bookmark" title="Mercer Boys And Girls Track Dominate Danville Allcomers">Mercer Boys And Girls Track Dominate Danville Allcomers</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2022/05/04/mercer-boys-and-girls-track-dominate-danville-allcomers/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.harrodsburgherald.com/2022/05/04/talking-with-sandra-defoor-about-the-mercer-county-health-department/" rel="bookmark" title="Talking With Sandra DeFoor About The Mercer County Health Department"> <img width="300" height="300" src="https://www.harrodsburgherald.com/wp-content/uploads/2021/07/Ribbon-Cutting-Website-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.harrodsburgherald.com/2022/05/04/talking-with-sandra-defoor-about-the-mercer-county-health-department/" rel="bookmark" title="Talking With Sandra DeFoor About The Mercer County Health Department">Talking With Sandra DeFoor About The Mercer County Health Department</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> May 4, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.harrodsburgherald.com/2022/05/04/talking-with-sandra-defoor-about-the-mercer-county-health-department/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', '101 Ad', 1.00, {'nonInteraction': 1});" href="http://cometo101.com/" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', '101 Ad', 2.00, {'nonInteraction': 1});" src="https://www.harrodsburgherald.com/wp-content/uploads/2020/04/image0.gif" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><!-- Error, Ad (13) is not available at this time due to schedule/budgeting/geolocation/mobile restrictions! --></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>               
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 2.15200901 sec
Time to load cache: 2.15715098
Cache file created on: 2022-05-04T18:28:37+00:00
Current time: 2022-05-04T18:28:37+00:00
-->